PoseNetセットアップ(05/10)

プログラム
スポンサーリンク

色々やる前に、PoseNetをセットアップしてデータを取得してみる。
OSはUbuntuを使用します。

モジュールインストール

まずはnpmをインストールします。

$ sudo apt-get update
$ sudo apt install nodejs
$ nodejs -v
 v8.10.0
$ sudo apt install npm
$ npm -v
 3.5.2

yarnをインストールします。

$ sudo npm install --global yarn
$ yarn --version
 1.22.10

PoseNetセットアップ

とりあえすダウンロードします。

$ git clone https://github.com/tensorflow/tfjs-models

「posenet」に移動して実行します。と思ったらエラーになりました。nodejsのバージョンが古いとダメなようです。

$ yarn
 yarn install v1.22.10
 [1/4] Resolving packages…
 [2/4] Fetching packages…
 error chalk@4.1.0: The engine "node" is incompatible with this module. Expected version ">=10". Got "8.10.0"
 error Found incompatible module.
 info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.

nodejsのバージョンを上げます。ただ、そのままだとパスが異なるのでフルパス指定とかが必要。

$ sudo npm install n -g
$  sudo n stable
   installing : node-v14.16.1
        mkdir : /usr/local/n/versions/node/14.16.1
        fetch : https://nodejs.org/dist/v14.16.1/node-v14.16.1-linux-x64.tar.xz
 installed : v14.16.1 (with npm 6.14.12)
 Note: the node command changed location and the old location may be remembered in your current shell.
          old : /usr/bin/node
          new : /usr/local/bin/node
 To reset the command location hash either start a new shell, or execute PATH="$PATH"
$ nodejs -v
 v8.10.0
$ /usr/local/bin/node -v
 v14.16.1

そのため、aptでインストールしたnodejsは削除しておきます。

$ sudo apt purge -y nodejs npm
$ node -v
 v14.16.1
$ npm -v
 6.14.12

再度「posenet」に」移動してyarnを実行します。こんどは成功しました。

 $ yarn
 yarn install v1.22.10
 [1/4] Resolving packages…
 [2/4] Fetching packages…
 [3/4] Linking dependencies…
 [4/4] Building fresh packages…
 Done in 85.79s.
$ yarn build && yarn yalc publish
$ cd demo
$ yarn
$ yarn yalc link @tensorflow-models/posenet
$ yarn watch

で、起動できたかというとなぜかエラーになる。
疲れたので今日はここまで。

コメント

タイトルとURLをコピーしました